Central Print Service (CPS) service starts but CPS component shows offline. Error 404 is displayed on http://127.0.0.01/cps - c06229992
Using the steps below the administrator of the PrinterOn Enterprise solution is able to troubleshoot issues related to the Central Print Service (CPS) appearing offline.
Description:
- Windows service for central print service can be restarted but CPS component done not come online
- Page 404 error on http://127.0.0.1/cps and https://127.0.0.1/cps
- Error messages in the CPS log file references the "cps_config.xml'
Root Cause:
- Corrupted 'cps_config.xml' for various reasons one of which is the server running out of hard drive space and subsequently "cps_config.xml' can not be saved and gets corrupted
Resolution:
- Automatic backup of "cps_config.xml' located here by default: C:\Program Files (x86)\PrinterOn Corporation\Apache Tomcat\Conf
- The backup file name looks similar to this: "cps_config_17Jul10_1029_22.xml"
- Delete the existing "cps_config.xml' and rename one of the backup files to "cps_config.xml'
- Restart CPS service
NOTE:
Applies to PrinterOn Enterprise 2.x and later